<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>		
	<title>New Security Hole Puts Windows and Linux Users at Risk | Security | TechNewsWorld</title>
	<meta name="title" content="New Security Hole Puts Windows and Linux Users at Risk" />
	<meta name="description" content="If you are a Windows or Linux user, brace yourself for a long siege of vulnerability nightmares. The fix will be long and treacherous and could brick your computers. Eclypsium researchers have detailed a set of newly discovered vulnerabilities dubbed &quot;BootHole&quot; that opens up billions of Windows and Linux devices to attacks." />
	<meta name="keywords" content="Linux,healthcare" />
	<link rel="shortcut icon" href="/images/tnw_favicon.ico" type="image/x-icon" />
	<link rel="alternate" type="application/rss+xml" title="RSS" href="/perl/syndication/rssfull.pl" />
	<link rel="alternate" type="application/rss+xml" title="Podcasts" href="http://www.ectnews.com/data/podcast.xml" />
	<meta http-equiv="content-type" content="text/html;charset=ISO-8859-1;" />
	<meta name="viewport" content="width=device-width, maximum-scale=1" />
	
	<link rel="stylesheet" type="text/css" media="screen" href="/shared/general.css" />
	<link rel="stylesheet" type="text/css" media="screen"  title="screensheet" href="/shared/tnwscreen.css" />
	<link rel="stylesheet" type="text/css" href="/shared/mobilescreen.css" media="only screen and (max-width:480px)" />

	<link rel="alternate stylesheet" type="text/css" media="screen" title="printsheet" href="/shared/print.css" />
	<link rel="stylesheet" type="text/css" media="print"  href="/shared/general.css" />
	<link rel="stylesheet" type="text/css" media="print"  href="/shared/print.css" />
	<link rel="stylesheet" href="/shared/ajax/colorbox/colorbox.css" type="text/css" />
	<link rel="stylesheet" href="/shared/ajax/ui-lightness/jquery-ui-1.10.3.custom.min.css" type="text/css" />
	<link rel="image_src" href="http://www.technewsworld.com/ai/597899/vulnerability.jpg" />

	<script type="text/javascript" src="//www.ectnews.com/shared/ajax/jquery-1.11.0.min.js"></script>
	<script type="text/javascript" src="//www.ectnews.com/shared/ajax/jquery-ui-1.10.3.custom.min.js"></script>
	<script type="text/javascript" src="//www.ectnews.com/shared/ajax/colorbox/jquery.colorbox-min.js"></script>
	<script type="text/javascript" src="//www.ectnews.com/shared/general-jquery.js"></script>		<script type="text/javascript"><!--//<![CDATA[
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function() {
      var gads = document.createElement("script");
      gads.async = true;
      gads.type = "text/javascript";
      var useSSL = "https:" == document.location.protocol;
      gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
      var node =document.getElementsByTagName("script")[0];
      node.parentNode.insertBefore(gads, node);
     })();
	//]]>//--></script>
	<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-9357282-1');
	ga('send', 'pageview');
	</script>
<!-- Facebook Pixel -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '535191343593734');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=535191343593734&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel -->
<!-- Bombora -->
<script>
(function (w,d,t) {
  _ml = w._ml || {};
  _ml.eid = '82421';
  var s, cd, tag; s = d.getElementsByTagName(t)[0]; cd = new Date();
  tag = d.createElement(t); tag.async = 1;
  tag.src = 'https://ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth();
  s.parentNode.insertBefore(tag, s);
})(window,document,'script');
</script>
<!-- End Bombora -->
</head>
<body>
<div id="fb-root"></div>
<script type="text/javascript"><!--//<![CDATA[
  (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=502379303161829";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));//]]>//--></script>




	<!--ps: 200 crid: 10342:a-cc-4up-signup_topnav-1 cc:us s_c: px:0-->
	<style type="text/css">
div#tnavad a, div#tnavad a:visited, div#tnavad a:hover { color: #323232 !important; }
</style>
<div id="tnavad" style="background-color:#f3f3f3;font-size:18px;padding:10px 0px;font-weight:400;font-family:roboto;letter-spacing:2px;"><a href="" onclick=" { ENN_ad_wo(10342,'15960482159064','https://www.technewsworld.com/'); return false; }" onmouseover="status='https://www.ectnews.com/about/newsletters.xhtml?utm_source=enn&amp;utm_medium=topnav&amp;utm_campaign=newsletters_promo'; return true;" onmouseout="status=''; return true;"   >Explore Newsletters from ECT News Network &raquo; View Samples | Subscribe
</a></div>
	<img class="ct-10342-a-cc-4up-signup_topnav-1" src="/adsys/count/10342/?nm=a-cc-4up-signup_topnav-1&amp;ENN_rnd=15960482159064&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 200 crid: 10342:a-cc-4up-signup_topnav-1 cc:us-->
	
<div id="tnav">

	<div id="top-sitelinks" style="float:right">
	<a href="https://www.ecommercetimes.com/">E-BUSINESS</a> | <a href="https://www.technewsworld.com/">TECHNOLOGY</a> |  <a href="https://www.crmbuyer.com/">CRM</a> | <a href="https://www.linuxinsider.com/">LINUX</a> | <a href="https://www.ectnews.com/" id="toprow-ennlink">ECTNEWS.COM</a>
	</div>
	Welcome Guest | <a href='/perl/User.pl'>Sign In</a>
</div>
<div id="container-outer">
<div id="container">
<script type="text/javascript" language="JavaScript"><!--//<![CDATA[
ENN_site = 'tnw';
//]]>//--></script>

<div id="toprow">

	<a href="/"><img src="/images/2014/tnw-logo.png"  border="0" align="left" alt="TechNewsWorld.com" /></a>

	<div id="adtitle" class="adtitle" style="padding-top:13px">
	
	<!--ps: 65 crid: 10293:a-emg_tnw_728-1 cc:us s_c:10342 px:0-->
	<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: TechNewsWorld, size: 728x90 - Leaderboard */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758477, 4).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="https://static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
	<img class="ct-10293-a-emg_tnw_728-1" src="/adsys/count/10293/?nm=a-emg_tnw_728-1&amp;ENN_rnd=15960482155088&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 65 crid: 10293:a-emg_tnw_728-1 cc:us-->
	
	</div>
	
</div>		
<div class="printlogo"><a href="/"><img id="printlogo" src="/images/2014/tnw-logo.png" border="0" alt="" /></a></div>

<div id="topwrapper">
<div id="infospace">
	<div class="shim">
	<div id="infoslogo" style="display:none;float:left;">
	<a href="/"><img src="/images/2014/260x40-tnw.gif" width="260" height="40" border="0" /></a>
	</div>
	<form class="searchspace" method="get" action="/perl/search.pl" >
	<input type="image" class="searchbutton" src="/images/2014/magnifying-glass_23x19.png" alt="Search" /> <input type="text" id="sitesearch" name="query" class="searchbox" />
	<div class="auto_complete" id="sitesearch_auto_complete"></div>
	</form>
	<a class="infospace-link" href="/perl/section/tech-security/">Security</a>
	</div>
</div>

	<div id="topmenubar">
	<div id="topmenubar-shim" class="shim">
	<ul>
		<li><a href="https://www.technewsworld.com/perl/section/computing/">Computing</a>
		<ul>
		<li><a href="https://www.technewsworld.com/perl/section/software/">Applications</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/data-management/">Data Management</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/hardware/">Hardware</a>
			<ul>
			<li><a href="https://www.technewsworld.com/perl/section/chips/">Chips</a></li>
			<li><a href="https://www.technewsworld.com/perl/section/personal-computers/">Personal Computers</a></li>
			<li><a href="https://www.technewsworld.com/perl/section/servers/">Servers</a></li>
			</ul>
		</li>
		<li><a href="https://www.technewsworld.com/perl/section/operating-systems/">Operating Systems</a></li>
		</ul>
	</li>

	<li><a href="https://www.technewsworld.com/perl/section/internet/">Internet</a>
		<ul>
		<li><a href="https://www.technewsworld.com/perl/section/internet-of-things/">Internet of Things</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/online-entertainment/">Online Entertainment</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/search-tech/">Search Tech</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/social-networking/">Social Networking</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/web-apps/">Web Apps</a></li>
		</ul>
	</li>

	<li><a href="https://www.technewsworld.com/perl/section/IT/">IT</a>
		<ul>
		<li><a href="https://www.technewsworld.com/perl/section/developers/">Developers</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/it-leadership/">IT Leadership</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/network-management/">Network Management</a></li>
		</ul>
	</li>

	<li><a href="https://www.technewsworld.com/perl/section/mobile-tech/">Mobile Tech</a>
		<ul>
		<li><a href="https://www.technewsworld.com/perl/section/mobile-apps/">Mobile Apps</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/smartphones/">Smartphones</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/tablets/">Tablets</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/wearable-tech/">Wearable Tech</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/wireless-networking/">Wireless Networking</a></li>
		</ul>
	</li>

	<li><a href="https://www.technewsworld.com/perl/section/reviews/">Reviews</a></li>

	<li><a href="https://www.technewsworld.com/perl/section/tech-security/">Security</a>
		<ul>
		<li><a href="https://www.technewsworld.com/perl/section/cyber-security/">Cybersecurity</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/hacking/">Hacking</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/viruses-malware/">Malware</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/privacy/">Privacy</a></li>
		</ul>
	</li>

	<li><a href="https://www.technewsworld.com/perl/section/technology/">Technology</a>
		<ul>
		<li><a href="https://www.technewsworld.com/perl/section/audio-video/">Audio/Video</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/emerging-tech/">Emerging Tech</a>
			<ul>
			<li><a href="https://www.technewsworld.com/perl/section/artificial-intelligence/">Artificial Intelligence</a></li>
			<li><a href="https://www.technewsworld.com/perl/section/virtual-reality/">Virtual Reality</a></li>
			</ul>
		</li>
		<li><a href="https://www.technewsworld.com/perl/section/gaming/">Gaming</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/home-tech/">Home Tech</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/how-to/">How-To</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/photography/">Photography</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/science/">Science</a>
			<ul>
			<li><a href="https://www.technewsworld.com/perl/section/med-tech/">Health</a></li>
			<li><a href="https://www.technewsworld.com/perl/section/space/">Space</a></li>
			</ul>
		</li>
		<li><a href="https://www.technewsworld.com/perl/section/tech-buzz/">Tech Buzz</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/law/">Tech Law</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/transportation/">Transportation</a></li>
		<li><a href="https://www.technewsworld.com/perl/section/women-in-tech/">Women In Tech</a></li>

		</ul>
	</li>
	<li><a href="/perl/section/tech-blog/">Tech Blog</a></li>
	<li style="float: right; width: auto;">&nbsp;Reader Services&nbsp;
	<ul>
	<li><a href="https://www.ectnews.com/perl/User.pl">Account Management</a></li>
	<li><a href="https://www.ectnews.com/perl/board/mboard.pl">Discussion</a></li>
	<li><a href="https://www.ectnews.com/about/newsalerts/">News Alerts</a></li>
	<li><a href="https://www.ectnews.com/perl/newsletter_registration.pl">Newsletters</a></li>
	<li><a href="/perl/surveys">Reader Surveys</a></li>
	<li><a href="https://www.ectnews.com/about/link-to-us.xhtml#rss">RSS / <img style="vertical-align:middle" src="/images/2004/xml_36x14.gif" border="0" alt='XML' /> Headline Feeds</a></li>
	
	
	
	<li><a href="https://www.ectnews.com/perl/search.pl">Search ECT News Network</a></li>
	<li class="hrule"></li>
	<li><a href="http://www.ectnews.com/about/network_map.xhtml">ECT News Network Map</a>
		<ul>
		<li><a href="https://www.crmbuyer.com/site_map/">CRM Buyer Site Map</a></li>
		<li><a href="https://www.ecommercetimes.com/site_map/">E-Commerce Times Site Map</a></li>
		<li><a href="https://www.linuxinsider.com/site_map/">LinuxInsider Site Map</a></li>
		<li><a href="https://www.technewsworld.com/site_map/">TechNewsWorld Site Map</a></li>
		</ul>
	</li>
	</ul>
</li>


	</ul>
	</div>
	</div>
	<script type="text/javascript" language="JavaScript"><!--//<![CDATA[
	new ENN_menu(document.getElementById("topmenubar-shim"));
	//]]>//--></script>
</div>


<div id="middlewrapper">
<div id="breadcrumb">
<!--<div id="snav" style=""><a href="/perl/board/mboard.pl/">DISCUSSION</a> | <a href="/perl/newsletter_registration.pl/">NEWSLETTERS</a> | <a href="http://www.ectnews.com/perl/User.pl/">ACCOUNT MGMT</a></div>-->
<div id="snav" style="">July 29, 2020 11:43:35 AM PDT</div>


	<!-- bc -->
	<span id="bcdata">
	<a href="/">TechNewsWorld</a> &gt; <a href="/perl/section/tech-security/">Security <!--tnw--></a>
	|  
	</span>
	<!-- /bc -->
	
</div>
<!-- [% IF !NO_PRINTER_COPYRIGHT %] -->
<script type="text/javascript"><!--//<![CDATA[
document.write('<div class="printer-copyright">');
document.write('Please note that this material is copyright protected. It is illegal to display or reproduce this article without permission for any commercial purpose, including use as marketing or public relations literature. ');
document.write('To obtain reprints of this article for authorized use, please call a sales representative at (818) 461-9700 or visit <a href="http://www.ectnews.com/about/reprints/">http://www.ectnews.com/about/reprints/</a>.');
document.write('</div>');
//]]>//--></script>
<!-- [% END %] -->



<div id="content-main">
	<div class="content-block">
	<!-- content-main -->
	<div id="story">

<h1 class="title">New Security Hole Puts Windows and Linux Users at Risk</h1>
 
<div id="story-byline">
	<!--byline-->By Jack M. Germain<!--/byline-->
	<br />
	<!--date-->Jul 29, 2020 10:10 AM PT<!--/date-->
	</div>
<script type="text/javascript"><!--//<![CDATA[
	var ENN_sc_u = 'http://www.technewsworld.com/story/86778.html';
	var ENN_sc_t = 'New%20Security%20Hole%20Puts%20Windows%20and%20Linux%20Users%20at%20Risk';
	var ENN_sc_b = 'If%20you%20are%20a%20Windows%20or%20Linux%20user,%20brace%20yourself%20for%20a%20long%20siege%20of%20vulnerability%20nightmares.%20The%20fix%20will%20be%20long%20and%20treacherous%20and%20could%20brick%20your%20computers.%20Eclypsium%20researchers%20have%20detailed%20a%20set%20of%20newly%20discovered%20vulnerabilities%20dubbed%20%22BootHole%22%20that%20opens%20up%20billions%20of%20Windows%20and%20Linux%20devices%20to%20attacks.';
	ENN_a_sview('jack_m_germain',86778);
	//]]>//--></script>
<div id="story-graphic-xlarge" style="text-align:center"><img alt="Eclypsium identifies BootHole computer security vulnerability" data-c="a" src="/article_images/story_graphics_xlarge/xl-2015-cybersecurity-skull-1.jpg" width="620" height="455" border="0" />
<div class="graphic-credit"><img src="/images/2015/image-credit-adobe-stock_130x15.gif" alt="" /></div>
</div>

<div id="story-body"><p class="story-body">If you are a Windows or Linux user, brace yourself for a long siege of vulnerability nightmares. The fix will be long and treacherous and could brick your computers.</p>
<p><a href="https://eclypsium.com/" target="_blank">Eclypsium</a> researchers Wednesday released details of a set of newly discovered vulnerabilities dubbed "BootHole" that opens up billions of Windows and Linux devices to attacks.</p>
<p>This is a serious vulnerability with a Common Vulnerability Scoring System (CVSS) rating of 8.2. The highest assigned rating on this severity scale is 10.</p>
<p>The BootHole vulnerability in the GRUB2 bootloader opens up Windows and Linux devices using Secure Boot to attack. To mitigate the attack surface, all operating systems using GRUB2 with Secure Boot must release new installers and bootloaders, the researchers warned.</p>
<p>Attackers exploiting this vulnerability could gain near-total control of the compromised device. The majority of laptops, desktops, servers, and workstations are affected, as well as network appliances and other special-purpose equipment used in industrial, healthcare, financial, and other industries, according to the report.</p>
<p>Researchers warned that mitigating this vulnerability will require the specific vulnerable program to be signed and deployed. They also advised that vulnerable programs should be revoked to prevent adversaries from using older, vulnerable versions in an attack.</p>
<p>Plugging this vulnerability hole will likely be a long process. It will take considerable time for IT departments within organizations to complete patching, the researchers said.</p>
<p>Eclypsium has coordinated the responsible disclosure of this vulnerability with a wide variety of industry entities, including OS vendors, computer manufacturers, and the Computer Emergency Response Team (CERT). A number of these organizations are listed in the report and were part of Wednesday's coordinated disclosure.</p>
<p>"This is probably the most widespread and severe vulnerability that we have found at Eclypsium. Many of the issues we found in the past were specific to a given vendor or model, whereas this issue is pervasive. This vulnerability in Secure Boot affects the default configuration of most systems deployed in the past decade, Jesse Michael, principal researcher for Eclypsium, told TechNewsWorld.</p>
<p>This vulnerability was assigned CVE-2020-10713 GRUB2.
</p>
<h2 class="subhead">
Finding and Patching Holes in the Boot
</h2>
<p>
The Eclypsium researchers stumbled on the trail of BootHole vulnerabilities somewhat by accident while doing some routinely proactive exploring, according to Michael.</p>
<p>"We were exploring any weak links in the whole secure boot infrastructure. Since we had previously seen a <a href="https://github.com/ValdikSS/Super-UEFIinSecureBoot-Disk" target="_blank">similar issue</a>
 with Secure Boot and the Kaspersky boot loader, we thought we should take a deeper look at that area. We did some fuzzing on GRUB2, which is widely used by most Linux distributions, and found a vulnerability that turned out to be much larger than we expected," he said.</p>
<p>Fuzzing, or fuzz testing, is an automated software testing technique to find hackable software bugs. Testers randomly provide different permutations of data into a target program until one of those permutations reveals a vulnerability.</p>
<p>Researchers have yet to see bad guys exploiting this specific vulnerability in the wild, he noted. But threat actors have been using malicious Unified Extensible Firmware Interface (UEFI) bootloaders.</p>
<p>"This sort of attack has been used by malware, including wipers and ransomware, for a long time, and Secure Boot was designed to protect against this technique. The BootHole vulnerability makes most devices susceptible even when Secure Boot is enabled. Previous threat actors used malware tampering with legacy OS bootloaders including APT41 Rockboot, LockBit, FIN1 Nemesis, MBR-ONI, Petya/NotPetya, and Rovnix," Michael noted.
</p>
<h2 class="subhead">
What BootHole Does
</h2>
<p>
Attackers can leverage the GRUB2 bootloader that most Linux systems and Windows computers use to gain arbitrary code execution during the boot process. This can happen even when Secure Boot is enabled. Attackers exploiting this vulnerability can install persistent and stealthy bootkits or malicious bootloaders that could give them near-total control over the victim device, according to Eclypsium's report.</p>
<p>What makes this BootHole vulnerability even more threatening is its ability to affect systems using Secure Boot, even if they are not using GRUB2. Almost all signed versions of GRUB2 are vulnerable. This means that nearly every Linux distribution is affected. In addition, GRUB2 supports other operating systems, kernels, and hypervisors such as Xen.</p>
<p>This problem also extends to any Windows device that uses Secure Boot with the standard Microsoft Third-Party UEFI Certificate Authority. Thus, BootHole affects the majority of laptops, desktops, servers, and workstations. The vulnerability also threatens network appliances and other special purpose equipment used in industrial, healthcare, financial, and other industries. This vulnerability makes these devices susceptible to attackers such as the threat actors recently discovered using malicious UEFI bootloaders, noted researchers at Eclypsium.</p>
<p>If the Secure Boot process is compromised, attackers can control how the operating system is loaded and subvert all higher-layer security controls. Recent research identified ransomware in the wild using malicious EFI bootloaders as a way to take control of machines at the time of boot. Previously threat actors used malware tampering with legacy OS bootloaders including APT41 Rockboot, LockBit, FIN1 Nemesis, MBR-ONI, Petya/NotPetya, and Rovnix, noted the report.
</p>
<h2 class="subhead">
Circular Firing Squad
</h2>
<p>
Attackers can also use a vulnerable bootloader against the system, the report writers added. For example, if BootHole finds a valid bootloader with a vulnerability, it can replace a piece of malware in the device's existing bootloader with the vulnerable version.</p>
<p>The bootloader would be allowed by Secure Boot and give the malware complete control over the system and the operating system itself. Mitigating this requires very active management of the dbx database used to identify malicious or vulnerable code.
<hr noshade="noshade" size="1" />
<div style="width:620px; float:none" class="story-thumbnail">
<img src="/article_images/2020/86778_secure-boot-process.jpg" width="620" height="150" border="0"  alt="Secure Boot process problems from Eclypsium BootHole report" />
<div style="text-align:left;font-size:14px;line-height:1.6;padding-top:8px;">The Secure Boot process has potential problems with many pieces of code. A vulnerability in any one of them presents a single point of failure that could allow an attacker to bypass Secure Boot, according to Eclypsium's BootHole report.</div>
</div>
<hr noshade="noshade" size="1" />
Additionally, trying to fix the vulnerabilities that BootHole seeks can be potentially deadly to the hardware and software. Updates and fixes to the Secure Boot process can be particularly complex. The complexity poses the additional risk of inadvertently breaking machines.</p>
<p>The boot process by nature involves a variety of players and components including device OEMs, operating system vendors, and administrators. The boot process's fundamental nature makes any sort of problems along the way poses a high risk of rendering a device unusable. As a result, updates to Secure Boot are typically slow and require extensive industry testing.
</p>
<h2 class="subhead">
Buffer Contributor
</h2>
<p>
The BootHole vulnerability is a buffer overflow that occurs in GRUB2 when parsing the grub configuration file, according to Eclypsium's researchers. The GRUB2 configuration file (grub.cfg) is merely a text file. It is typically not signed like other files and executable code.</p>
<p>This vulnerability enables arbitrary code execution within GRUB2 and ultimately control over the booting of the operating system. As a result, an attacker could modify the contents of the GRUB2 configuration file to ensure that attack code is run before the operating system is loaded. In this way, attackers gain persistence on the device, according to the report.</p>
<p>To pull off such an intrusion, the attacker would need elevated privileges. But it would provide the attacker with a powerful additional escalation of privilege and persistence on the device. This would occur with or without Secure Boot enabled and properly performing signature verification on all loaded executables. 
</p>
<h2 class="subhead">
Challenging Mitigation Effort
</h2>
<p>
Eclypsium warned that plugging BootHole will require the release of new installers and bootloaders for all versions of Linux and potentially Windows. Vendors will have to release new versions of their bootloader shims signed by the Microsoft Third-Party UEFI CA.</p>
<p>Until all affected versions are added to the dbx revocation list, an attacker would be able to use a vulnerable version of shim and GRUB2 to attack the system. This means that every device that trusts the Microsoft Third-Party UEFI CA will be vulnerable for that period of time.
<hr noshade="noshade" size="1" />
<div style="width:620px; float:none" class="story-thumbnail">
<img src="/article_images/2020/86778_secure-boot-keys.jpg" width="620" height="380" border="0"  alt="Secure Boot Keys" />
<div style="text-align:left;font-size:14px;line-height:1.6;padding-top:8px;">The Unified Extensible Firmware Interface (UEFI) Forum originally developed Secure Boot as a way to protect the boot process from these types of attacks.</div>
</div>
<hr noshade="noshade" size="1" />
This configuration file is an external file commonly located in the EFI System Partition and can therefore be modified by an attacker with administrator privileges without altering the integrity of the signed vendor shim and GRUB2 bootloader executables.</p>
<p>The buffer overflow allows the attacker to gain arbitrary code execution within the UEFI execution environment, which could be used to run malware, alter the boot process, directly patch the OS kernel, or execute any number of other malicious actions.</p>
<p>This vulnerability is not architecture specific. It is in a common code path and was also confirmed using a signed ARM64 version of GRUB2.</p>
<p><a class="story-keyword-offsite" href="https://canonical.com/" onclick="window.open('https://canonical.com/'); return false;">Canonical's</a> security team found additional vulnerabilities related to the GRUB2 code in response to the Eclypsium report, the Eclypsium report noted. That will further impact on the mitigation path.</p>
<p>"Those vulnerabilities discovered by the Canonical security team were all of medium severity. There were also dozens of further vulnerabilities identified by other organizations that do not yet have individual CVEs assigned, said Michael.
</p>
<h2 class="subhead">
What's Needed to Fix
</h2>
<p>
Full mitigation will require coordinated efforts from affected open-source projects, Microsoft, and the owners of affected systems, among others. The list of tasks to fix BootHole, according to the report, will include:
</p><ul>
<li>Updates to GRUB2 to address the vulnerability.</li>
<li>Linux distributions and other vendors using GRUB2 will need to update their installers, bootloaders, and shims.</li>
<li>New shims will need to be signed by the Microsoft 3rd Party UEFI CA.</li>
<li>Administrators of affected devices will need to update installed versions of operating systems in the field as well as installer images, including disaster recovery media.</li>
<li>Eventually the UEFI revocation list (dbx) needs to be updated in the firmware of each affected system to prevent running this vulnerable code during boot.</li>
</ul><p>
<h2 class="subhead">
More Bugaboos Possible
</h2>
Full deployment of this revocation process to enterprises will likely be very slow, researchers suggested. UEFI-related updates have a history of making devices unusable. So, vendors will need to be very cautious to prevent the fix from turning computers into bricks.</p>
<p>For example, if the revocation list (dbx) is updated, the system will not load. So vendors will have to apply revocation list updates over time to prevent breaking systems that have yet to be updated.</p>
<p>Also, cases exist where updating the dbx can be difficult. The edge conditions involve computers with dual-boot or deprovisioned setups.</p>
<p>Other circumstances can further complicate matters. For instance, enterprise disaster recovery processes can run into issues where approved recovery media no longer boots on a system if dbx updates have been applied.</p>
<p>Another situation is when a device swap is needed due to failing hardware. New systems of the same model may have already had dbx updates applied and will fail when attempting to boot previously-installed operating systems. So before dbx updates are pushed out to enterprise fleet systems, recovery and installation media must be updated and verified as well.
</p>
<h2 class="subhead">
Few Workarounds
</h2>
<p>
With the report's dire warnings about boot fixes bricking hardware, few potential workarounds exist to prevent the cure being worse than the attack results. Michael expects attacks will occur that take advantage of this, if they haven't already.</p>
<p>"If left without action or mitigation, this will leave a gaping hole on all affected systems," he said. "There could be unexpected consequences to the cure as well."</p>
<p>Revocation updates are not common, and this is going to be the largest revocation ever done. Bugs in this rarely used part of firmware, could cause systems to behave unexpectedly after the update. In order to avoid such issues, the revocation will not happen automatically. 
"This forces security teams to carefully manage this issue using manual intervention," cautioned Michael.</p>
<p>Workarounds may need to be tweaked by various vendors to be effective for their products. Bootloader vulnerabilities have been found in the past that vendors successfully patched, according to Charles King, principal analyst at <a class="story-keyword-offsite" href="https://www.pund-it.com/" onclick="window.open('https://www.pund-it.com/'); return false;">Pund-IT</a>.</p>
<p>For example, one was revealed in March that affected LG phones, and in June the company <a href="https://hothardware.com/news/lg-bootloader-flaw" target="_blank">announced</a>
 that it had issued a patch for phones going back seven years.
</p>
<h2 class="subhead">
What's Worse: Meltdown and Spectre or BootHole?
</h2>
<p>
The Meltdown and Spectre vulnerabilities of 2019 impacted confidentiality. They allow an attacker to steal secrets.</p>
<p>This vulnerability impacts integrity and availability, as well as confidentiality. Therefore, BootHole has the potential for much broader damage, according to Michael.</p>
<p>Using the industry-standard CVSS severity score, Meltdown and Spectre were classified as Medium severity vulnerabilities, and BootHole is rated as a High severity vulnerability, he said.</p>
<p>While the BootHole vulnerability occurs in software (system firmware), Meltdown and Spectre exploited hardware flaws that were baked into many CPUs. A major challenge with Meltdown and Spectre has been that fixes often significantly impact CPU performance, noted King.</p>
<p>"It seems unlikely that BootHole fixes will similarly impact system or device performance," he told TechNewsWorld.</p>
<p>As to which vulnerability is more dangerous is relative. Just because a vulnerability exists does not mean that people will find a way to effectively exploit it. Though Meltdown and Spectre attracted a great deal of attention when they were revealed several years ago, he has not seen any reports of successful exploits, King said.
</p>
<h2 class="subhead">
What to Do
</h2>
<p>
Most users will want to deploy the updates that vendors are coming out with beginning on July 29, Michael suggested.  In addition to the automatic updates released by OS vendors, manual action will be needed to revoke the old, vulnerable versions of grub.</p>
<p>"Until this is done, systems will remain vulnerable," he warned.</p>
<p>Enterprise security teams should also consider threat hunting or monitoring activities that look at the bootloaders present on operational systems, suggested Michael. This should reveal which systems have suspicious-looking bootloaders and grub configuration files.</p>
<p>"Considering the complexity of deploying these updates to an enterprise, such monitoring may be an important workaround to buy time while updates are tested and deployed," Michael concluded.</p>
<p>The Eclypsium report is available <a href="https://eclypsium.com/2020/07/29/theres-a-hole-in-the-boot/" target="_blank">here</a>. 
<img src="//www.ectnews.com/images/end-enn.gif" width="21" height="10" border="0" />


</p>
<hr noshade="noshade" size="1" /><p id="story-authorbio"><img src="/images/rws572389/Jack M. Germain.jpg" align="left" />
<strong>Jack M. Germain</strong> has been an ECT News Network reporter since 2003. His main areas of focus are enterprise IT, Linux and open-source technologies. He is an esteemed reviewer of Linux distros and other open-source software. In addition, Jack extensively covers business technology and privacy issues, as well as developments in e-commerce and consumer electronics. <a href="mailto:jack.germain@newsroom.ectnews.com">Email Jack.</a><br clear="all" />
</p></div>

</div>

<hr noshade="noshade" size="1" />


		
		<style>
		#shareleft { display: absolute; position: fixed; top: 250px; margin-left: -125px; }
		.st_twitter_hcount, .st_facebook_hcount, .st_linkedin_hcount, .st_plusone_hcount,.st_sharethis_hcount, .st_pinterest_hcount, .st_stumbleupon_hcount {
			display: block;
			margin-bottom: 15px;
		}
		.st_plusone_hcount { margin-left: 3px }
		</style>
		<script type="text/javascript" src="https://ws.sharethis.com/button/buttons.js"></script>
		<script type="text/javascript">stLight.options({publisher:'aa1224c6-b198-4ba7-8912-a0e9e2e5e489', mobileWidget: "true", doNotCopy: "true"});</script>

		<div id="shareleft" style="margin-bottom: 10px">
		<!--<span class="st_plusone_hcount" displayText="+1" st_url="https://www.technewsworld.com/story/86778.html" st_title="New Security Hole Puts Windows and Linux Users at Risk"></span>-->
		<span class="st_twitter_hcount" displayText="Tweet" st_url="https://www.technewsworld.com/story/86778.html" st_title="New Security Hole Puts Windows and Linux Users at Risk" st_via="technewsworld"></span>
		<span class="st_facebook_hcount" displayText="Share" st_url="https://www.technewsworld.com/story/86778.html" st_title="New Security Hole Puts Windows and Linux Users at Risk"></span>
		<span class="st_linkedin_hcount"  st_url="https://www.technewsworld.com/story/86778.html" st_title="New Security Hole Puts Windows and Linux Users at Risk"></span>
		<!--<span class="st_stumbleupon_hcount" displayText="Share" st_url="https://www.technewsworld.com/story/86778.html" st_title="New Security Hole Puts Windows and Linux Users at Risk"></span>-->
		<span class="st_sharethis_hcount" displayText="Share" st_url="https://www.technewsworld.com/story/86778.html" st_title="New Security Hole Puts Windows and Linux Users at Risk"></span>
		</div>	
		<!--<div style="position:absolute;right:0px;bottom:100px" class="fb-like" data-href="https://www.technewsworld.com/story/86778.html" data-send="false" data-layout="button_count" data-width="450" data-show-faces="true" data-font="verdana"></div>-->
		
		
		<p id="story-toolbox2">
		
		<div id="cccperms">
		<div style="margin-bottom: 10px;height:18px; line-height:18px;">
		<a target="_blank" href="https://www.copyright.com/search!detail.action?item=123672089&detailType=basic"><img style="vertical-align:middle; margin-right: 5px;" width="16" height="18" border="0" src="/images/2013/ccc-button.png" />Get Permission to License or Reproduce this Article</a>
		</div>
		<span style="white-space: nowrap;"><img src="/images/2006/icon_reprint_20x14.gif" alt="" width="20" height="14" border="0" /><a href="http://www.ectnews.com/about/reprints.xhtml">Reprints</a></span>
<span style="white-space: nowrap;"><img src="/images/work/icon_search_20x14.gif" alt="" width="20" height="14" border="0" /><a href="#searchbyline">More by Jack M. Germain</a></span></div></p>
 
 
<div class="story-advertisement-2">
	<!--ps: 122 crid: 10346:a-cc-tnflash-signup_640-2 cc:us s_c:10342,10293 px:0-->
	<a href="" onclick=" { ENN_ad_wo(10346,'15960482154681','https://www.technewsworld.com/'); return false; }" onmouseover="status='https://lp.constantcontactpages.com/su/TFH4rVy/TechNewsFlash'; return true;" onmouseout="status=''; return true;"   ><img src="/images/sda/newsletter-promo-technewsflash_640x420.png" width="640" height="420" border="0" alt="Subscribe to Tech News Flash Newsletter" /></a>
	<img class="ct-10346-a-cc-tnflash-signup_640-2" src="/adsys/count/10346/?nm=a-cc-tnflash-signup_640-2&amp;ENN_rnd=15960482154681&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 122 crid: 10346:a-cc-tnflash-signup_640-2 cc:us-->
	</div>
 
 
<div class="story-advertisement-2">
	<!--ps: 122 crid: 10401:a-emg_tnw_300x2-1 cc:us s_c:10346,10342,10293 px:0-->
	<table style="width:100%">
<tr>
<td>
<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: TechNewsWorld, size: 300x250 - Medium Rectangle */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758477, 5).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="https://static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script></td>
<td>
<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: TechNewsWorld, size: 300x250 - Medium Rectangle */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758477, 5).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="https://static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script></td>
</tr>
</table>
	<img class="ct-10401-a-emg_tnw_300x2-1" src="/adsys/count/10401/?nm=a-emg_tnw_300x2-1&amp;ENN_rnd=15960482153413&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 122 crid: 10401:a-emg_tnw_300x2-1 cc:us-->
	</div>
 	<!--/content-block-->
	</div>
<!--/content-main-->
</div>

<div id="content-nav">
	
	<div id="shortcuts" class="content-block">
		<div class="headline-item">
		<table cellpadding="0" cellspacing="0" border="0" width="100%" height="14"><tr><td align="left"><img src="//www.ectnews.com/images/2015/icon_mostpop_14x14roundcorner.png" width="14" height="14" border="0" /> <a class="headline" href="/perl/mostpop/">Most Popular</a></td><td align="center"><img src="//www.ectnews.com/images/2012/icon_newsletter_16x12.png" width="16" height="12" border="0" /> <a class="headline" href="https://www.ectnews.com/about/newsletters.xhtml">Newsletters</a></td><td align="right"><img src="//www.ectnews.com/images/2012/icon_alert_14x14.png" width="14" height="14" border="0" /> <a class="headline" href="https://www.ectnews.com/about/newsalerts/">News Alerts</a></td></tr></table>
		</div>
	</div>
	
	
	
	
	<div class="right-bb">
	
	<!--ps: 107 crid: 10294:a-emg_tnw_300-1 cc:us s_c:10401,10346,10342,10293 px:0-->
	<div class="bbframe">
<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: TechNewsWorld, size: 300x250 - Medium Rectangle */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758477, 5).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="https://static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
</div>
	<img class="ct-10294-a-emg_tnw_300-1" src="/adsys/count/10294/?nm=a-emg_tnw_300-1&amp;ENN_rnd=15960482153168&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 107 crid: 10294:a-emg_tnw_300-1 cc:us-->
	
	</div>

	

			
			<div class="survey" style="border: solid 1px #cbcbcb">
			<div class="survey-description" style="background-color:#eeeeee;font-weight:bold">Should virtual fans be used on TV broadcasts of sporting events during the pandemic?</div>
			<div class="survey-body" style="padding:5px">
			<form>
			<input type="hidden" name="survey_id" value="284" />
			<table>
			
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="1650" /></td><td>Yes -- This use of VR technology helps to bring a sense of normalcy to the game atmosphere and is more entertaining while sports are played in empty stadiums.</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="1651" /></td><td>Perhaps -- It's an interesting idea while human fans are not allowed to attend games. However it's unfair for the TV networks to control how the crowd looks and reacts to everything during the game.</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="1652" /></td><td>No -- Virtual fans are creepy and cannot substitute for humans. I prefer to watch games with empty seats while human fans are not allowed to attend.</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="1653" /></td><td>It does not matter to me because I do not watch sports on TV.</td>
				</tr>
		
			</table>
			<div class="survey-vote"><button onclick="return ENN_vote(this.form)">Vote to See Results</button></div>
			</form>
			</div>
			</div>
			
	
	<div class="content-tab border-ect"><a class="content-block-intro" href="https://www.ecommercetimes.com/">E-Commerce Times</a></div>
	<div class="content-block">
	
			<div class="headline-item" id="rhd-86773">
			<a href="http://www.ecommercetimes.com/story/86773.html" >Website Development Contracts, Part 5: Mediating Disputes</a>
			</div>
			

			<div class="headline-item" id="rhd-86771">
			<a href="http://www.ecommercetimes.com/story/86771.html" >Victory Gardens 2.0: Gardening in the Pandemic Era</a>
			</div>
			

			<div class="headline-item" id="rhd-86769">
			<a href="http://www.ecommercetimes.com/story/86769.html" >Panic Buying Sparks New E-Tail Strategies</a>
			</div>
			

			<div class="headline-item" id="rhd-86762">
			<a href="http://www.ecommercetimes.com/story/86762.html" >Fitness Products Shatter Online Sales Records During Lockdown</a>
			</div>
			

			<div class="headline-item" id="rhd-86760">
			<a href="http://www.ecommercetimes.com/story/86760.html" >New E-Commerce Partnership Gives U.S. Merchants Access to LATAM</a>
			</div>
			

			<div class="headline-item" id="rhd-86757">
			<a href="http://www.ecommercetimes.com/story/86757.html" >How to Win at E-Commerce on the New Walmart.com</a>
			</div>
			

			<div class="headline-item" id="rhd-86744">
			<a href="http://www.ecommercetimes.com/story/86744.html" >The Art of Sewing's Hi-Tech Revival</a>
			</div>
			

			<div class="headline-item" id="rhd-86746">
			<a href="http://www.ecommercetimes.com/story/86746.html" >Website Development Contracts, Part 4: Indemnification</a>
			</div>
			
	</div>

	<div class="right-bb">
	
	<!--ps: 71 crid: 10294:a-emg_tnw_300-1 cc:us s_c:10401,10346,10342,10294,10293 px:0-->
	<div class="bbframe">
<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: TechNewsWorld, size: 300x250 - Medium Rectangle */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758477, 5).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="https://static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
</div>
	<img class="ct-10294-a-emg_tnw_300-1" src="/adsys/count/10294/?nm=a-emg_tnw_300-1&amp;ENN_rnd=15960482155652&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 71 crid: 10294:a-emg_tnw_300-1 cc:us-->
	
	</div>
	
	<div class="content-tab border-cad"><a class="content-block-intro" href="https://www.crmbuyer.com/">CRM Buyer</a></div>
	<div class="content-block">
	
			<div class="headline-item" id="rhd-86765">
			<a href="http://www.crmbuyer.com/story/86765.html" >Salesforce Ups Its Marketing Game</a>
			</div>
			

			<div class="headline-item" id="rhd-86763">
			<a href="http://www.crmbuyer.com/story/86763.html" >Refocus Your Sales Strategy on the Phone Call</a>
			</div>
			

			<div class="headline-item" id="rhd-86753">
			<a href="http://www.crmbuyer.com/story/86753.html" >Improving Company Performance</a>
			</div>
			

			<div class="headline-item" id="rhd-86739">
			<a href="http://www.crmbuyer.com/story/86739.html" >B2C Response Rates at SMBs Crushing Enterprises</a>
			</div>
			

			<div class="headline-item" id="rhd-86736">
			<a href="http://www.crmbuyer.com/story/86736.html" >The Trail to the Platform</a>
			</div>
			

			<div class="headline-item" id="rhd-86724">
			<a href="http://www.crmbuyer.com/story/86724.html" >Let's Rethink Our Relationship With CRM</a>
			</div>
			

			<div class="headline-item" id="rhd-86716">
			<a href="http://www.crmbuyer.com/story/86716.html" >Time to Beef Up Your Algorithms</a>
			</div>
			

			<div class="headline-item" id="rhd-86710">
			<a href="http://www.crmbuyer.com/story/86710.html" >The WFH Model Is Changing Customer Service for Good</a>
			</div>
			
	</div>

	<div class="right-bb">
	
	<!--ps: 108 crid: 10294:a-emg_tnw_300-1 cc:us s_c:10401,10346,10342,10294,10293 px:0-->
	<div class="bbframe">
<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: TechNewsWorld, size: 300x250 - Medium Rectangle */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758477, 5).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="https://static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
</div>
	<img class="ct-10294-a-emg_tnw_300-1" src="/adsys/count/10294/?nm=a-emg_tnw_300-1&amp;ENN_rnd=15960482154880&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 108 crid: 10294:a-emg_tnw_300-1 cc:us-->
	
	</div>

	<div class="content-tab border-lni"><a class="content-block-intro" href="https://www.linuxinsider.com/">LinuxInsider</a></div>
	<div class="content-block">
	
			<div class="headline-item" id="rhd-86774">
			<a href="http://www.linuxinsider.com/story/86774.html" >The Case Against Full-Disk Encryption</a>
			</div>
			

			<div class="headline-item" id="rhd-86767">
			<a href="http://www.linuxinsider.com/story/86767.html" >Rancher Labs and Fujitsu Form Kubernetes Partnership as Suse Readies Merger</a>
			</div>
			

			<div class="headline-item" id="rhd-86759">
			<a href="http://www.linuxinsider.com/story/86759.html" >AutoTux Is a Real Distro With a 'No Hands' Linux Installer</a>
			</div>
			

			<div class="headline-item" id="rhd-86754">
			<a href="http://www.linuxinsider.com/story/86754.html" >The Linux Foundation's First-Ever Virtual Open Source Summit</a>
			</div>
			

			<div class="headline-item" id="rhd-86742">
			<a href="http://www.linuxinsider.com/story/86742.html" >The Current State of Open-Source Testing Tools</a>
			</div>
			

			<div class="headline-item" id="rhd-86729">
			<a href="http://www.linuxinsider.com/story/86729.html" >Open Source Security Issues Exist: Deal With Them, Report Urges</a>
			</div>
			

			<div class="headline-item" id="rhd-86719">
			<a href="http://www.linuxinsider.com/story/86719.html" >Ubuntu Unity Distro: An Unofficial Desktop Revival</a>
			</div>
			

			<div class="headline-item" id="rhd-86708">
			<a href="http://www.linuxinsider.com/story/86708.html" >PsychOS: A Crazy Cool Distro That Pushes Linux Limits</a>
			</div>
			
	</div>
	
	
	<!--ps: 172 crid: 3217:a_sponsored_links cc:us s_c:10401,10346,10342,10294,10293 px:0-->
	
<!-- slinks -->
	<div class="content-tab-slinks">POPULAR RESOURCES</div>
	<div class="content-block-slinks">

				<div class="slink-title">What is the ROI of PIM?</div>
				<div class="slink-text"><a href="" onclick=" { ENN_ad_wo(10351,'15960482153370'); return false; }" onmouseover="status='https://www.inriver.com/resources/calculate-your-roi-2/?utm_source=ecommercetimes&amp;utm_medium=onlinemedia&amp;utm_campaign=2020-q1-na-campaign-roi-calculator-ecommercetimestextads'; return true;" onmouseout="status=''; return true;"  ><img src="/images/sda/inriver_60x60.jpg" width="60" height="60" border="0" align="right" />
Save money and get products to market faster with a PIM. Calculate your ROI now.</a><img class="ct-10351-a-inriver_stl-2" src="/adsys/count/10351/?nm=a-inriver_stl-2&amp;ENN_rnd=15960482153370&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" /></div>
				

				<div class="slink-title">Marketers - Fill Your Sales Funnel Instantly</div>
				<div class="slink-text"><a href="" onclick=" { ENN_ad_wo(8781,'15960482153370'); return false; }" onmouseover="status='https://www.ectnews.com/perl/ratecard.pl?lead_gen=1'; return true;" onmouseout="status=''; return true;"  ><img src="/images/sda/sales-funnel_60x60.jpg" width="60" height="60" border="0" align="right" />
Access millions of  IT and business decision makers. Our full-service global marketing program delivers sales-ready leads. Learn more.</a><img class="ct-8781-instaleads-stl-1" src="/adsys/count/8781/?nm=instaleads-stl-1&amp;ENN_rnd=15960482153370&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" /></div>
				
	</div>
<!-- /slinks -->

	<img class="ct-3217-a_sponsored_links" src="/adsys/count/3217/?nm=a_sponsored_links&amp;ENN_rnd=15960482153370&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 172 crid: 3217:a_sponsored_links cc:us-->
	

	<div class="right-bb">
	
	<!--ps: 126 crid: 10294:a-emg_tnw_300-1 cc:us s_c:10401,10346,3217,10342,10294,10293 px:0-->
	<div class="bbframe">
<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: TechNewsWorld, size: 300x250 - Medium Rectangle */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758477, 5).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="https://static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
</div>
	<img class="ct-10294-a-emg_tnw_300-1" src="/adsys/count/10294/?nm=a-emg_tnw_300-1&amp;ENN_rnd=15960482158598&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 126 crid: 10294:a-emg_tnw_300-1 cc:us-->
	
	</div>
	
	<div class="hslice" id="tnwheadlines"><a rel="feedurl" href="/shared_cs/navsliceupdate.xhtml" style="display:none;"></a><div class="entry-title" style="display:none">TechNewsWorld Headlines</div>

	<div class="content-tab border-tnw"><a class="content-block-intro" href="https://www.technewsworld.com/">TechNewsWorld</a></div>
	<div class="content-block">
	
			<div class="headline-item" id="rhd-86777">
			<a href="http://www.technewsworld.com/story/86777.html" >Amazon Gives Alexa App a Makeover</a>
			</div>
			

			<div class="headline-item" id="rhd-86776">
			<a href="http://www.technewsworld.com/story/86776.html" >Garmin Confirms Services Upended by Ransomware Attack</a>
			</div>
			

			<div class="headline-item" id="rhd-86772">
			<a href="http://www.technewsworld.com/story/86772.html" >The Essential Need for 5G in the COVID World</a>
			</div>
			

			<div class="headline-item" id="rhd-86770">
			<a href="http://www.technewsworld.com/story/86770.html" >Beware of Counterfeit Network Equipment</a>
			</div>
			

			<div class="headline-item" id="rhd-86768">
			<a href="http://www.technewsworld.com/story/86768.html" >US Cloud Gaming Subscriptions Target $3B</a>
			</div>
			

			<div class="headline-item" id="rhd-86766">
			<a href="http://www.technewsworld.com/story/86766.html" >Windows 10X to Eliminate Onboard 32-Bit Apps: Report</a>
			</div>
			

			<div class="headline-item" id="rhd-86764">
			<a href="http://www.technewsworld.com/story/86764.html" >The Past, Present and Future of Attribute-Based Encryption</a>
			</div>
			

			<div class="headline-item" id="rhd-86761">
			<a href="http://www.technewsworld.com/story/86761.html" >Why Microsoft Teams Will Be the De Facto Standard for Video Collaboration</a>
			</div>
			
	</div>

	</div>

 
	<div class="right-bb">
	
	</div>


</div>

</div>



<div id="content-bottom">

<a name="inside-site"></a>

	
	<div id="lb2">
	
	<!--ps: 18 crid: 10293:a-emg_tnw_728-1 cc:us s_c:10401,10346,3217,10342,10294,10293 px:0-->
	<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: TechNewsWorld, size: 728x90 - Leaderboard */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758477, 4).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="https://static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
	<img class="ct-10293-a-emg_tnw_728-1" src="/adsys/count/10293/?nm=a-emg_tnw_728-1&amp;ENN_rnd=15960482155523&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 18 crid: 10293:a-emg_tnw_728-1 cc:us-->
	
	</div>
	





	
	<div id="lb3" class="lb2">
	
	<!--ps: 164 crid: 10379:a-wit_nowavail_970-1-lb2-3 cc:us s_c:10401,10346,3217,10342,10294,10293 px:0-->
	<a href="" onclick=" { ENN_ad_wo(10379,'15960482159982','https://www.ectnews.com/'); return false; }" onmouseover="status='https://www.amazon.com/dp/B088X497SR/ref=sr_1_1?dchild=1&amp;qid=1589997156&amp;refinements=p_27%3AVivian+Wagner&amp;s=digital-text&amp;sr=1-1&amp;text=Vivian+Wagner'; return true;" onmouseout="status=''; return true;"   ><img src="/images/sda/WIT-970-banner-v1.jpg" width="970" height="200" border="0" alt="Women in Tech" /></a>
	<img class="ct-10379-a-wit_nowavail_970-1-lb2-3" src="/adsys/count/10379/?nm=a-wit_nowavail_970-1-lb2-3&amp;ENN_rnd=15960482159982&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 164 crid: 10379:a-wit_nowavail_970-1-lb2-3 cc:us-->
	
	</div>
	


</div>
</div>
</div>

<div id="footer-container">
<div id="footer">

	<table class="headlines-section publication-info">
	<tr>
	<td valign="top"><div><a href="https://www.ectnews.com/about/advertising/#publications">Publications</a></div>
	<ul>
	<li><a class="headline" href="https://www.crmbuyer.com/">CRM Buyer</a></li>
	<li><a class="headline" href="https://www.ecommercetimes.com/">E-Commerce Times</a></li>
	<li><a class="headline" href="https://www.linuxinsider.com/">LinuxInsider</a></li>
	<li><a class="headline" href="https://www.technewsworld.com/">TechNewsWorld</a></li>

	</ul>
	<div id="bottom-logo" style="position: absolute;width:455px; height:125px; margin-top:10px"><a href="https://www.ectnews.com/"><img src="/images/2013/enn-logo-bottom.png" align="left" width="455" height="125" border="0" style="margin-left: -5px;" alt="ECT News Network" /></a></div>

	</td>
	<td valign="top" style="padding-left:50px"><div><a href="https://www.ectnews.com/about/newsletters.xhtml">Newsletters</a></div>
	<ul>
	<li><a class="headline" href="https://lp.constantcontactpages.com/su/axVwPYf/EcommerceMinute?source_id=ae4c20aa-296f-4347-91ea-3c9ea552d171&source_type=em&c=">E-Commerce Minute</a></li>
	<li><a class="headline" href="https://lp.constantcontactpages.com/su/TFH4rVy/TechNewsFlash?source_id=ae4c20aa-296f-4347-91ea-3c9ea552d171&source_type=em&c=">Tech News Flash</a></li>
	<li><a class="headline" href="https://lp.constantcontactpages.com/su/U1kaHbw/ECTNewsNetworkWeekly?source_id=ae4c20aa-296f-4347-91ea-3c9ea552d171&source_type=em&c=">ECT News Network Weekly</a></li>
	<li><a class="headline" href="https://lp.constantcontactpages.com/su/D7Cw9Iz/EditorsPick?source_id=ae4c20aa-296f-4347-91ea-3c9ea552d171&source_type=em&c=">Editor's Pick</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/newsletters.xhtml">Subscribe</a></li>
	</ul>
	</td>

	<td valign="top">
	<div>Reader Services</div>
	<ul>
	<li><a class="headline" href="https://www.ectnews.com/perl/User.pl">Account Management</a></li>
	<li><a class="headline" href="https://www.ectnews.com/perl/board/mboard.pl">Discussion</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/editorial-calendar.xhtml">Editorial Calendar</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/link-to-us.xhtml">Linking Policy</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/network_map.xhtml">Network Map</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/newsalerts/">News Alerts</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/link-to-us.xhtml#rss">RSS / XML Feeds</a></li>
	<li><a class="headline" href="https://www.ectnews.com/perl/search.pl">Search ECT News Network</a></li>
	</ul>
	<table cellpadding="0" cellspacing="0" border="0">
		<tr>
		<td><a href="http://www.linkedin.com/company/ect-news-network" target="_blank"><img src="/images/2013/navicon-linkedin_20x20-gray.png" width="20" height="20" border="0" alt="LinkedIn" /></a></td>
		<td><a href="https://www.twitter.com/technewsworld" target="_blank"><img src="/images/2013/navicon-twitter_20x20-gray.png" width="20" height="20" border="0" alt="Twitter" /></a></td>
		<td><a href="https://www.facebook.com/ectnews" target="_blank"><img src="/images/2013/navicon-facebook_20x20-gray.png" width="20" height="20" border="0" alt="Facebook" /></a></td>
		<td><a href="http://www.ectnews.com/about/link-to-us.xhtml#rss" target="_blank"><img src="/images/2013/navicon-rss_20x20-gray.png" width="20" height="20" border="0" alt="RSS" /></a></td>
		</tr>
	</table>
	</td>
	<td valign="top" style="padding-left:10px"><div>Company Info</div>
	<ul>
	<li><a class="headline" href="https://www.ectnews.com/about/">About</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/advertising/">Advertising</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/bizdev.xhtml">Business Development</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/careers.xhtml">Careers</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/#contact">Contact</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/permissions.xhtml">Permissions</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/reprints/">Reprint Information</a></li>
	</ul>
	</td>
	</tr>
	</table>
	<div id="bottom-copyright">
		<div style="float:right;">
		<a class="bottom-copyright" href="https://www.ectnews.com/about/terms-of-service.xhtml">Terms of Service</a> | <a class="bottom-copyright" href="https://www.ectnews.com/about/privacy.xhtml">Privacy Policy</a> | <a class="bottom-copyright" href="http://www.ectnews.com/about/advertising/">How To Advertise</a>
		</div>
		Copyright 1998-2020 ECT News Network, Inc. All Rights Reserved.

	</div>
</div>
</div>






<!-- Start of HubSpot Embed Code -->
<script type="text/javascript" id="hs-script-loader" async defer src="//js.hs-scripts.com/4750620.js"></script>
<!-- End of HubSpot Embed Code -->
</body>
</html>
